Back to overview
Downtime

External Disruption: Multiple payment methods affected (cmismxcmj09mlk7rm9qpug3qn)

Dec 05 at 10:00am CET
Affected services
Payment provider - Mollie

Resolved
Dec 05 at 10:29am CET

RESOLVED - We have identified a full disruption external to our platform affecting iDEAL payments. You will see a decline in successful payments as consumers are unable to pay using this payment method. We are in close contact with our partners to resolve the issue and will provide updates as they become available.

Updated
Dec 05 at 10:28am CET

RESOLVED - We have identified a full disruption external to our platform affecting iDEAL payments. You will see a decline in successful payments as consumers are unable to pay using this payment method. We are in close contact with our partners to resolve the issue and will provide updates as they become available.

Updated
Dec 05 at 10:17am CET

MONITORING - We have identified a full disruption external to our platform affecting iDEAL payments. You will see a decline in successful payments as consumers are unable to pay using this payment method. We are in close contact with our partners to resolve the issue and will provide updates as they become available.

Updated
Dec 05 at 10:11am CET

IDENTIFIED - We have identified a full disruption external to our platform affecting iDEAL payments. You will see a decline in successful payments as consumers are unable to pay using this payment method. We are in close contact with our partners to resolve the issue and will provide updates as they become available.

Created
Dec 05 at 10:00am CET

IDENTIFIED - We have identified a full disruption external to our platform affecting iDEAL payments. You will see a decline in successful payments as consumers are unable to pay using this payment method. We are in close contact with our partners to resolve the issue and will provide updates as they become available.