Back to overview
Downtime
Cards: minor disruption (cmnd9mcxk0axa12ny07qsg713)
Mar 30, 2026 at 2:10pm UTC
Affected services
Payment provider - Mollie
Resolved
Mar 30, 2026 at 2:33pm UTC
RESOLVED - We are currently investigating a minor disruption affecting Credit Cards payments. You may see a decline in successful payments as consumers may be unable to pay using this payment method. We will provide updates as they become available.
Affected services
Created
Mar 30, 2026 at 2:10pm UTC
INVESTIGATING - We are currently investigating a minor disruption affecting Credit Cards payments. You may see a decline in successful payments as consumers may be unable to pay using this payment method. We will provide updates as they become available.
Affected services