Back to overview
Downtime

Mollie API - Delays in Refunds (cmnj2ihbg0f094nalfp0jtub4)

Apr 3, 2026 at 3:38pm UTC
Affected services
Payment provider - Mollie

Resolved
Apr 3, 2026 at 5:14pm UTC

RESOLVED - We are investigating a disruption affecting our ability to process refunds. Users may experience a delay in refund processing.

Payment processing remains unaffected. We will provide updates as they become available.

Updated
Apr 3, 2026 at 5:09pm UTC

MONITORING - We are investigating a disruption affecting our ability to process refunds. Users may experience a delay in refund processing.

Payment processing remains unaffected. We will provide updates as they become available.

Created
Apr 3, 2026 at 3:38pm UTC

INVESTIGATING - We are investigating a disruption affecting our ability to process refunds. Users may experience a delay in refund processing.

Payment processing remains unaffected. We will provide updates as they become available.