Back to overview
Degraded

Mollie Business Accounts - Minor Disruption (cmqi5gblm05zx2jmuzqx1lkwz)

Jun 17, 2026 at 2:11pm UTC
Affected services
Payment provider - Mollie

Resolved
Jun 17, 2026 at 2:39pm UTC

RESOLVED - We have identified an issue that is preventing some users from accessing their Business Account pages through desktop.

Please be assured that this is a display issue only. All core services, including payment processing and the Mollie mobile app, are fully operational and unaffected.

We will provide further updates as soon as we have more information.

Updated
Jun 17, 2026 at 2:34pm UTC

MONITORING - We have identified an issue that is preventing some users from accessing their Business Account pages through desktop.

Please be assured that this is a display issue only. All core services, including payment processing and the Mollie mobile app, are fully operational and unaffected.

We will provide further updates as soon as we have more information.

Created
Jun 17, 2026 at 2:11pm UTC

IDENTIFIED - We have identified an issue that is preventing some users from accessing their Business Account pages through desktop.

Please be assured that this is a display issue only. All core services, including payment processing and the Mollie mobile app, are fully operational and unaffected.

We will provide further updates as soon as we have more information.