Terug naar overzicht
Uitvaltijd

Dashboard: disruption to Settlement Report page (cmn4qfgob0afuv52emu560cir)

Mar 24, 2026 at 2:51pm UTC
Getroffen services
Payment provider - Mollie

Opgelost
Mar 24, 2026 at 3:15pm UTC

RESOLVED - We have identified a disruption affecting our dashboard. The Settlement Report page is experiencing a disruption.

We are working to resolve the issue and will provide updates as they become available.

Aangemaakt
Mar 24, 2026 at 2:51pm UTC

IDENTIFIED - We have identified a disruption affecting our dashboard. The Settlement Report page is experiencing a disruption.

We are working to resolve the issue and will provide updates as they become available.