Terug naar overzicht
Uitvaltijd

External - iDEAL | Wero: full disruption at Knab (cmn7mh24n08scn1odir5506bz)

Mar 26, 2026 at 3:23pm UTC
Getroffen services
Payment provider - Mollie

Opgelost
Mar 26, 2026 at 4:56pm UTC

RESOLVED - Knab is experiencing a full disruption affecting iDEAL | Wero payments and consumers will experience failures attempting to complete payments.

We will provide further updates as soon as we have more information.

Aangemaakt
Mar 26, 2026 at 3:23pm UTC

IDENTIFIED - Knab is experiencing a full disruption affecting iDEAL | Wero payments and consumers will experience failures attempting to complete payments.

We will provide further updates as soon as we have more information.